Erro ao executar o root.sh do Grid Infrastructure 12.2.0.1 no Red Hat Enterprise Linux 7.3 64bits

Conforme pode ser verificado através da matrix  de compatibilidade do Oracle Grid Infrastructure 12cR2 que a versão do database e Grid 12.2 são homologadas para a versão 7 do Red Hat Enterprise Linux, conforme imagem abaixo.
Durante o processo de instalação, quando é solicitada a instalação do root.sh, tivemos o erro abaixo.
[root@server01 grid]# sh /oraprd01/app/12.2.0.1/grid/root.sh 
Performing root user operation. 

The following environment variables are set as: 
ORACLE_OWNER= grid 
ORACLE_HOME= /oraprd01/app/12.2.0.1/grid 

Enter the full pathname of the local bin directory: [/usr/local/bin]: /usr/local/bin 
The contents of "dbhome" have not changed. No need to overwrite. 
The contents of "oraenv" have not changed. No need to overwrite. 
The contents of "coraenv" have not changed. No need to overwrite. 

Entries will be added to the /etc/oratab file as needed by 
Database Configuration Assistant when a database is created 
Finished running generic part of root script. 
Now product-specific root actions will be performed. 
Using configuration parameter file: /oraprd01/app/12.2.0.1/grid/crs/install/crsconfig_params 
The log of current session can be found at: 
/oraprd01/app/grid/crsdata/stoprda01/crsconfig/roothas_2017-06-26_03-14-37PM.log 
2017/06/26 15:14:43 CLSRSC-330: Adding Clusterware entries to file 'oracle-ohasd.service' 
2017/06/26 15:14:49 CLSRSC-214: Failed to start the resource 'ohasd' 
Failed to start the Clusterware. Last 20 lines of the alert log follow: 

2017/06/26 15:14:50 CLSRSC-318: Failed to start Oracle OHASD service 
Died at /oraprd01/app/12.2.0.1/grid/crs/install/crsinstall.pm line 2775. 
The command '/oraprd01/app/12.2.0.1/grid/perl/bin/perl -I/oraprd01/app/12.2.0.1/grid/perl/lib -I/oraprd01/app/12.2.0.1/grid/crs/install /oraprd01/app/12.2.0.1/grid/crs/install/roothas.pl ' execution failed 
[root@server01 grid]# 
Apos varias tentativas de prosseguir a instalação sem sucesso, abrimos um chamado com a Oracle para verificação do problema. No chamado foi constatado que este é um bug sem correção até o momento e ocorre nas versão 3.10.0-514.21.2.el7.x86_64 do kernel. Para podermos prosseguir com o processo de instalação, foi preciso realizar um downgrade da versão do kernel para 3.10.0-514.21.1.el7.x86_64 
Como não havia achado nenhuma informação a respeito deste bug, resolvi criar este post para registro desta informação.

SHARE

Jhonata Lamim

  • Image
  • Image
  • Image
  • Image
  • Image