[INS-08101] Unexpected error while executing the action at state: 'supportedOSCheck'

Durante a instalação do Oracle database 19c em um ambiente Oracle Linux 8.5, estava ocorrendo o erro abaixo.


[root@serverdbtasy ~]# cat /etc/oracle-release Oracle Linux Server release 8.5 [root@serverdbtasy ~]#

Conforme consta na matriz de certificação do Oracle Database 19c, o mesmo é homologado para o Oracle Linux 8.x, e não deveríamos ter erro durante a sua instalação.

Esse erro ocorre devido a instalação que esta sendo utilizada estar sendo a release base 19.3.0.0. Para evitar o erro é possível aplicar o workaround abaixo ou aplicar o último PSU disponível antes de instalar o produto.
  • Exportar a variável CV_ASSUME_DISTD='OL7' antes de executar o instalador.

Uma alternativa melhor é aplicar o último PSU disponível para a instalação. Desta forma o erro não será apresentado. Neste exemplo, apliquei o PSU 19.14.

[oracle@serverdbtasy ContentsXML]$ cd /orabin01/app/oracle/product/19.0.0.0/dbhome_1/ [oracle@serverdbtasy dbhome_1]$ [oracle@serverdbtasy dbhome_1]$ ./runInstaller -silent -applyRU /orabackup/33509923/33515361 Preparing the home to patch... Applying the patch /orabackup/33509923/33515361... Successfully applied the patch. The log can be found at: /orabin01/app/oraInventory/logs/InstallActions2022-03-11_01-52-35PM/installerPatchActions_2022-03-11_01-52-35PM.log Launching Oracle Database Setup Wizard...


SHARE

Jhonata Lamim

  • Image
  • Image
  • Image
  • Image
  • Image

0 Comments:

Postar um comentário